搜索

LzyAMP是本站推出的Windows+Apache+PHP+Mariadb环境配置包,该程序包集成最新的Apache 2.4 +PHP 5.6/7.0+MariaDB 5.5+phpMyAdmin+Zend Guard Loader(仅限PHP5.6版本)。一键安装,非常方便、好用的PHP调试环境。总之学习PHP只需一个包。
对学习PHP的新手来说,Windows下环境配置是一件很困难的事;对老手来说也是一件烦琐(说烦琐也没多烦琐)的事。因此无论你是新手还是老手,该程序包都是一个不错的选择。

LzyAMP开发环境配置包

该开发环境配置包支持目前主流Windows操作系统(Windows Vista/Server 2008以上版本操作系统),因PHP和Apache停止支持Windows XP/Server 2003,因此本包不支持Windows XP/Server 2003操作系统。

该程序包集成以下软件,均为目前主流版本。

  1. PHP 5.6/7.0 新型的CGI程序编写语言,易学易用、速度快、跨平台。
  2. Apache 2.4 最流行的HTTP服务器软件,快速、可靠、开源。
  3. MariaDB 5.5 执行性能高,运行速度快,容易使用,非常常用的数据库。
  4. phpMyAdmin 小巧的MySQL在线管理程序。
  5. Zend Guard Loader 免费的PHP优化引擎,性能提高30%以上。
  6. OpenSSL 1.0.2k  密码算法库、SSL协议库以及应用程序。

安装说明

  1. 为了减少出错安装路径不得有空格和汉字,如有防火墙开启,会提示是否信任httpd、mysqld运行,请选择全部允许。
  2. 因目前暂未实现自动替换配置文件目录,因此安装使用前请用文本编辑器将配置文件所有的“E:/LzyAMP/Build"替换为实际安装路径。

需要替换的配置文件:
Apache/conf目录下的httpd.conf httpd_php70.conf
php56目录和php70目录的php.ini

3、菜单文件:根目录menu.cmd(请用管理员权限运行)

  1. 重装系统后或相关服务丢失时,只需要通过菜单重新安装服务即可。
  2. 可通过菜单中的相关软件菜单进行卸载相关服务。
  3. 端口问题无法启动时,请使用菜单『环境端口检测』进行端口检测,尝试启动。
    7、MySQL数据库用户名:root,无密码,安装后请用phpMyAdmin重新设置密码。

系统服务和非服务启动的区别:
系统服务启动:开机就会启动,适合经常使用或做服务器,无需手工启动,服务会随开机而启动,好处程序运行稳定。
非服务启动:需要手动启动一下,适合偶尔经常使用一下。在不使用的情况不会启动相关进程,从而节省电脑的资源。

『特别声明』该程序没有任何商业目的,仅作开发学习之用,不得用于商业用途;该程序所包括的软件版权归原作者所有。对于使用此程序给您造成的任何损失,本人概不负责!

目前最新版本:1.0_20170610
下载地址:http://pan.baidu.com/s/1dFGfYqH 提取密码:bjt2
**2018年8月26日更新:
下载链接: https://pan.baidu.com/s/1JZpFrMX_iFpCYFGCOii-jQ 密码: qn2t**

Windows PHP SSL 密码 文件 开发 程序

版权属于:lzy20021010
作品采用:本作品采用 知识共享署名-相同方式共享 4.0 国际许可协议 进行许可。
0
查看目录

目录

来自 《LzyAMP开发环境配置包发布》
评论

Lzy20021010